Released 2x XenForo 2.2.11 Released | XenForo 2.2.11 Released null | Add-ons Released

PVS

Cộng Sự Đặc Biệt
Thành viên BQT
Tham gia
28/02/2015
Bài viết
15,191
Được Like
11,583
XenForo 2.2.11 Released | XenForo 2.2.11 Released null | Add-ons Released

Today, we are releasing XenForo 2.2.11 to address a potential security vulnerability. We recommend that all customers running XenForo 2.2 upgrade to 2.2.11 or use the attached patch file as soon as possible.

The issue relates to HTML attribute injection which can be triggered when rendering editor content, such as when a post is edited or quoted.

We recommend doing a full upgrade to resolve the issues, but a patch can be applied manually. See below for further details.

Note: There are no other changes in this release and any work previously done towards XenForo 2.2.11 - including a new CAPTCHA option by Cloudflare Turnstile and various bug fixes and improvements - will be released alongside XenForo 2.2.12 in the coming weeks.

Applying a patch manually​

Download the 2211patch.zip file attached to this message. It will contain the following file:
  1. src/XF/BbCode/Renderer/EditorHtml.php
Extract the zip file to your computer and upload the contents to the root of your XenForo installation. This should overwrite the files on your server with the new version.

Note: If you decide to patch the files instead of doing a full upgrade, your "File health check" will report this file as having "Unexpected contents". Because these files no longer contain the same contents your version of XF was shipped with, this is expected and can be safely ignored.

As always, new releases of XenForo are free to download for all customers with active licenses, who may now grab the new version from the customer area or upgrade from your Admin control panel (Tools > Check for upgrades...).

Current requirements​

Please note that XenForo 2.2 has higher system requirements than earlier versions.

The following are minimum requirements:
  • PHP 7.0 or newer (PHP 8.0 recommended)
  • MySQL 5.5 and newer (Also compatible with MariaDB/Percona etc.)
  • All of the official add-ons require XenForo 2.2.
  • Enhanced Search requires at least Elasticsearch 2.0.
 

Đính kèm

  • xenforo_2.2.11_upgrade_NULL_VNXF.zip
    13.6 MB · Lượt xem: 78
  • xenforo_2.2.11_full_NULL_VNXF.zip
    13.6 MB · Lượt xem: 168

itseovn

Thượng Đế
Tham gia
21/05/2015
Bài viết
23
Được Like
8
Giờ muốn update từ forum xenforo 1.5.4 thì có bị lỗi gì không bạn
 

thahtrung06

Thượng Đế
Tham gia
12/11/2019
Bài viết
910
Được Like
391
Lên rồi bác ơi, bản này gọi là bản đệm cho 2.2.12 thôi bác ạ
Có bản vá lỗi thủ công, có thể sử dụng bản này để vá lỗi bảo mật thay vì phải nâng cấp lên 2.2.11. Dưới đây là bản và lỗi cho Xenforo từ 2.2.6 trở lên, còn bạn nào sử dụng Xenforo từ 2.2.0 -> 2.2.5 thì inbox cho mình để lấy bản vá lỗi nhé!
Nguồn download: Xenforo.com
 

Đính kèm

  • 2211patch.zip
    5.2 KB · Lượt xem: 5

Hướng dẫn sử dụng

XenForo 1 XenForo 2
Translate by PVS

Hỗ trợ trực tuyến

Support Quảng cáo
Mr. San (PVS)

Skype chat, instant message

Mr. Tuấn (Blue)

Skype chat, instant message

Mr. Tuấn
0988 488 096
Mr. Trọng
0906 081 284
kinhdoanh@vnxf.vn

Nhà Tài Trợ

Mút Xốp Không Gian
pallet Thịnh Phát
Điện Lạnh Thịnh Phát
Top Bottom