Hướng dẫn Setup SSL/HTTP tương thích với Xenforo - Fix lỗi không load được CSS trên SSL/HTTPS của Xenforo

CraftVN

Private
Tham gia
10/06/2016
Bài viết
25
Được Like
30
Chào mấy bạn, đối với nhiều bạn mới tiếp xúc với Xenforo/SSL thì chắc hẳn đã gặp vấn đề này:
Screenshot (86).png

Ta daaaa... Ủa, theme của tớ biến đi đâu mất rồi???
(Khi không có SSL: Screenshot (86).png)

Đừng lo, đã có ngay giải pháp.
Đầu tiên, các bạn hãy vào config của Xenforo (nằm ở your_xenforo_file/library/config.php)
Sau đó, hãy làm như sau:
  • Add thêm dòng này vào:
  • PHP:
    $_SERVER['HTTPS'] = 'on';
Dòng đó làm được gì?
Nó sẽ làm cho Xenforo load content 100% = SSL/HTTPS và sẽ không bị lỗi theme nữa!

Mình đã thử và thành công. Bị lỗi? Comment bên dưới và để nhiều bạn giúp (có cả mình) :V
 

Đính kèm

  • Screenshot (78).png
    Screenshot (78).png
    90.7 KB · Lượt xem: 43

CraftVN

Private
Tham gia
10/06/2016
Bài viết
25
Được Like
30
À quên nói thêm, cái SSL này lợi gì? Nếu forum của bạn mới, hãy sử dụng CloudFlare, lấy SSL miễn phí, qua phần page rules thêm Always use HTTPS, config thêm HTTPS cho forum. Vừa lên Google Search Machine ez mà có vẻ uy tín nữa :3
 

daklak1985

MasterCorporal
Tham gia
01/09/2016
Bài viết
216
Được Like
68
Trong host đó bạn, ở chỗ /library/config.php ấy, add thêm dòng
PHP:
$_SERVER['HTTPS'] = 'on';
vào nhé!
lúc nãy nhà cung cấp host chuyển cpanel host của tớ sang 1 server khác thì không truy cập đc forum đc nữa,truy cập cái là bị tình trạng giống như bạn nói ở trên,không biết có phải do lỗi như bạn nói hay không nữa,giờ truy cập cpanel host không đc nữa này,làm sao bây giờ ;(
 
  • Like
Reactions: THB

CraftVN

Private
Tham gia
10/06/2016
Bài viết
25
Được Like
30
lúc nãy nhà cung cấp host chuyển cpanel host của tớ sang 1 server khác thì không truy cập đc forum đc nữa,truy cập cái là bị tình trạng giống như bạn nói ở trên,không biết có phải do lỗi như bạn nói hay không nữa,giờ truy cập cpanel host không đc nữa này,làm sao bây giờ ;(
Sao bạn không gọi cho chủ host báo bạn bị như thế?..
Chứ không vào được FTP/VPS thì làm sao chỉnh được nhỉ...
 
  • Like
Reactions: THB

daklak1985

MasterCorporal
Tham gia
01/09/2016
Bài viết
216
Được Like
68
Sao bạn không gọi cho chủ host báo bạn bị như thế?..
Chứ không vào được FTP/VPS thì làm sao chỉnh được nhỉ...
host tận bên Srilanka tớ báo rồi mà không thấy hồi âm,nhưng admin ACP Xen thì vẫn truy cập bình thường facepalm~~
 
  • Like
Reactions: THB

phamngocduy98

Private
Tham gia
15/12/2015
Bài viết
1
Được Like
1
Xenforo 2 vẫn bị lỗi css bạn ơi @@
thêm
PHP:
$_SERVER['HTTPS'] = 'on';
vào /src/config.php không được @@
 
  • Like
Reactions: THB

t2hol

Gefreiter
Tham gia
12/03/2015
Bài viết
53
Được Like
46
Nên nói rõ là áp dụng cho Xenforo v1 hay v2 hay cả hai version
 
  • Like
Reactions: THB

THB

Founder
Thành viên BQT
Tham gia
25/02/2015
Bài viết
6,649
Được Like
3,938
cái này phải cài đặt thêm trong ACP nữa. Mình nhớ vnxf có 1 bài hướng dẫn cái ssl này rồi. bác nào bị lỗi thì tìm ngâm cứu nhé. Chỉ thêm trong config là chưa đủ.
 

Nguoi Chia Se

MasterCorporal
Tham gia
26/12/2016
Bài viết
266
Được Like
131

Top Bottom