Help Help me!!! Lỗi 404 khi chuyển sang chế độ URL friendly

cudem205

Private
Tham gia
16/06/2015
Bài viết
13
Được Like
8
chào mọi người, hiện tại mình đang làm 1 website: abc.com và forum: abc.com/forum/index.php.
Khi mình chuyển sang chế độ url friendly thì mất index.php, nhưng các link của forums, thread list...đều bị lỗi 404, mình tìm hiểu thì sửa trong file htaccess nhưng vẫn không có tác dụng. Mọi người giúp mình vấn đền này nhé. Thanks!

Đây là file htaccess bên mình:
Mã:
#    Mod_security can interfere with uploading of content such as attachments. If you
#    cannot attach files, remove the "#" from the lines below.
#<IfModule mod_security.c>
#    SecFilterEngine Off
#    SecFilterScanPOST Off
#</IfModule>
ErrorDocument 401 default
ErrorDocument 403 default
ErrorDocument 404 default
ErrorDocument 500 default
<IfModule mod_rewrite.c>
    RewriteEngine On
RewriteRule t([\d]+)-([\d]+)/ /threads/$1?page=$2 [L,R=301]
RewriteRule t([\d]+)/ /threads/$1 [L,R=301]
RewriteRule f([\d]+)-([\d]+)/ /forums/$1?page=$2 [L,R=301]
RewriteRule f([\d]+)/ /forums/$1 [L,R=301]
    #    If you are having problems with the rewrite rules, remove the "#" from the
    #    line that begins "RewriteBase" below. You will also have to change the path
    #    of the rewrite to reflect the path to your XenForo installation.
    #RewriteBase /xenforo
    #    This line may be needed to enable WebDAV editing with PHP as a CGI.
    #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -l [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^.*$ - [NC,L]
    RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
</IfModule>
 
  • Like
Reactions: THB

Bon

MasterCorporal
Tham gia
22/03/2016
Bài viết
254
Được Like
255
Tắt cái romanize đi là được . Nhớ đổi file htacess.txt thành .htacess nhé
image.png
 
  • Like
Reactions: THB

cudem205

Private
Tham gia
16/06/2015
Bài viết
13
Được Like
8
Vẫn không được bạn ơi, mình đã xóa file htaccess.txt luôn, chỉ để .htaccess lại vẫn bị 404 :(
 
  • Like
Reactions: THB

Bon

MasterCorporal
Tham gia
22/03/2016
Bài viết
254
Được Like
255
Xoá .htacess trên host đi rồi úp cái htacess mặc định của xenforo lên
 
  • Like
Reactions: THB

thuyet951

MasterCorporal
Tham gia
01/04/2016
Bài viết
312
Được Like
427
Khả năng lổi là do host, liên hệ hỗ trợ bên nhà cung cấp host xem sao.
 
  • Like
Reactions: THB

cudem205

Private
Tham gia
16/06/2015
Bài viết
13
Được Like
8
Cho mình hỏi, nếu để mặc định url vậy thì mình làm SEO vẫn bình thường chứ ạ?
 
  • Like
Reactions: THB

htmart2604

Private
Tham gia
05/04/2017
Bài viết
6
Được Like
0
fix mãi chưa được

HTmart - Giải pháp quản lý siêu thị. Chuyên cung cấp Thiết bị siêu thị, mã số mã vạch, phần mềm quản lý siêu thị, thiết bị an ninh siêu thị, giải pháp quản lý kho hàng
 
Sửa lần cuối:

pdinh97qng

MasterCorporal
Tham gia
12/05/2015
Bài viết
229
Được Like
218
;) Hosting phải có hàm curl và phải sử dụng apache (Cpanel, Directadmin, zPanel,...) Những hệ thống khác phải viết lại (nginx, plesk)
 

Hướng dẫn sử dụng

XenForo 1 XenForo 2
Translate by PVS

Dịch vụ XenForo của VNXF

Telegram: anhanhxf

Chỉ nhận web nội dung lành mạnh

Nhà Tài Trợ

Mút Xốp Không Gian
Mút Sofa Không Gian
Top Bottom